PHPを導入しよう

HTTPサーバーでPHPを使えるようにします。
PHPはHypertext Preprocessorの略ですね。
CGI同様動的なページを作成するのに用いられるプログラム言語です。
PHPとCGIはHTTPサーバーを、サイトを運営するには、サーバーを運営にするには必須と言って良いでしょう。

そんなPHPですが、現在はPHP4とPHP5一般的に利用されています。

しかしPHP4系そのものが2007年末を持ってサポート終了がアナウンスされています。
ですから今後新規にPHPをインストールする場合はPHP5をお勧めします。

PHP4を導入しよう

PHP5を導入しよう